CMS솔루션마켓, 이온디 - 워드프레스, 라이믹스, 카페24, 그누보드, 엑셀
XE팁
본 게시판은 운영을 중지합니다.
라이믹스 팁 게시판으로 바로가기

출처 : https://xe1.xpressengine.com/tip/23323881

xpresseditor.tar.gz 


XE 1.4에 머물러야 하는 분들이 있는 것 같습니다. 1.4가 잘 만들어진 이유도 있고 1.5에서 바뀐것이 많아 업그레이드가 어려워, 계속 머물러 있다보니 그대로 굳어진 것으로 생각됩니다. 단 한가지 문제가 플래시로 동작하는 파일 업로드 버튼이 안되는 것 빼면요.

기존 다운로드 자료실의 Xpresseditor + AXISJ AXUpload5(HTML5) 에디터 를 사용하면 되지만, XE 1.5 이상에서만 동작합니다. XE 1.4에서 동작하려면 몇줄을 수정해야 해야 합니다. 방법을 질문게시판에서 알려드려 봤지만 별 도움이 안되는 것 같아, 파일을 이글의 첨부 파일로 업로드 합니다. 원본이 LGPL이니까 이렇게 올려도 상관 없겠지요.?~?~~!!!!

설치 방법:

1. /modules/editor/skins/xpresseditor 를 삭제(혹은 xpresseditor-old 등으로 이름을 변경)하고, 

2. 첨부한 xpresseditor.tar.gz 를 다운받아 압축을 풀어 같은 폴더로 그대로 복사합니다. - 끝 -

   (즉, /modules/editor/skins/xpresseditor )

기존 폴더와 이름이 같게 해주면 관리자 페이지에서 아무런 설정을 안해줘도 그냥 동작할 것입니다. 이 기회에 XE를 업그레이드 해보셔도 좋지만, 굳이 잘 도는 것을 손대고 싶지 않은 분들도 있을 것 같습니다. 이런경우, XE 1.4에 당분간 계속 머물고 싶으시면 구글 검색해보면 XE 1.4.5.24 인가 버전이 있습니다. 보안패치가 많이 된 것이라 조금 낫습니다. 

이 기회에 XE 1.8.x로 먼저 업그레이드 해보시고(파일/DB는 백업 필수), 잘 되면 그 다음 XE 1.11 또는 라이믹스 등으로 변경해보시는 것도 추천드립니다.